Citrix XenDesktop 5.6 – Desktop Studio DB Connection fails after installing Hotfix Update 4

I am doing a HDX 3D Pro POC in Oslo with Morten Waler, and we bumb into an critical issue with a vanilla Citrix XenDesktop 5.6 Controller, after applying Hotfix update 4 for Citrix XenDesktop 5.6.

If you install a fresh new Citrix XenDesktop 5.6 Controller installation and apply the latest Hotfix update 4, normal you would have a button in the XenDesktop Studio dashboard saying if you want to upgrade the database this is the case with Hotfix update packages before Hotfix update 4. With Hotfix update 4 applied on a vanilla XenDesktop environment there is no upgrade database button, and if you configure the environment and create “Desktop Groups” and assign users to them, you will get and DB connection error.

Doug Nuveen from the Citrix forum, came up with this solution:

  • Uninstall Desktop Studio
  • Uninstall Broker Service
  • Uninstall Broker Powershell Snap-In

Next, install the same components from the XenDesktop 5.6 iso.

Here comes the critical part, CREATE YOUR FIRST DESKTOP GROUP! There is clearly some bug in Hotfix Update 4 that does not enable the DB Upgrade button in the Dashboard if you dont have any Desktop Groups when you run the update.

Next, install the updates from Hotfix Update 4.

  • Broker Service
  • Broker Powershell Snap-In
  • Desktop Studio from XD560DStudioWX64002

Open Desktop Studio and go to Dashboard, you should now see a button to upgrade. Hit it, select Automatic. BAM! It’s all good. Well for us that is, other users are reporting that they have problems doing the upgrade automatic and manual.


Kudos to Doug Nuveen & Morten Waler for confirming this issue and the above solution works 😉

A message to Citrix

Citrix, could you please test your XenDesktop Hotfix Update’s on your vanilla systems, before you ship them to the market.

Leave a Reply

Your email address will not be published. Required fields are marked *

Turn on pictures to see the captcha *