Warning: Declaration of YOOtheme\Theme\Wordpress\MenuWalker::walk($elements, $max_depth) should be compatible with Walker::walk($elements, $max_depth, ...$args) in /home/poppelga/public_html/wp-content/themes/yootheme/vendor/yootheme/theme-wordpress/src/MenuWalker.php on line 8

Citrix VDI-in-a-box (Kaviza) 4.1.5 W2k12 bug

W2K12 bug in Citrix VDI-in-a-box 4.1.5

Let me start to say Happy New Year and hope that you have come good into 2012. Well some of you have and some of you don’t and i know a lot of customers around the world haven’t started 2012 with a fresh start. Customers that are using Citrix VDI-in-a-box (kaviza) 4.1.5 has a major bug so users have no access to their VDI when they connect with HDX from their devices. Many companies was down the first january 2012 and some customers found a quick turnaround that they where able to connect to their VDI by switching from HDX to RDP. But for many other customers this was a “no go” solution  if they had users with devices like Wyse Xenith that only works with HDX.

Citrix created a private hot fix for the issue 3rd January 2012 and for many customers people where not able to work for 3 days.  Citrix is working on a public release of the fix that will come out to the community as quickly as possible.

I really love Citrix VDI-in-a-box because its so simplified but this behavior is a big flaw and Citrix really have to persuade why customers still should keep using Citrix VDI-in-a-box because many companies can’t live with having their environments down for 1-3 days.

Workarounds

Workarounds have been found by some, the first is to revert back to RDP and stop using HDX which is a valid workaround but some of you may not have this luxury if you are running in kiosk mode.

Another workaround is to set back the date on the servers to 2011 which seems again to work, but if you have software running dependent on the server dates, then again this may not work.

Temporary Quick fix

Citrix has just now released a quick fix and some administrator have succesfuld tested the solution.

Check the Citrix forum message from http://forums.citrix.com/thread.jspa?threadID=299469&start=30&tstart=0

We are in the process of building private fix for this issue and we have an early build available.
Please be aware that this is a build straight from our engineering team and did not undergo full test cycle so please test it in your test environment first.
This requires editing the image of the VDA at the moment but we are working on automating patching process.

The package contains the fix for version 4.x (ctxlicense.dll) and 5 (VdaEnvironment.dll) of VDI-in-a-box.
You will need to replace the file on your image:

For ctxlicense.dll replace C:Program FilesCitrixICAServiceCtxLicense.dll

RDP into current desktop and replace the file
You might need to path an existing image (please refer to Patching an existing image, Administrator Guide)
You might need to build new image (please refer to Creating new image versions, Administrator Guide)
You might need to restart Citrix ICA Services or the machine

For VdaEnvironment.dll replace C:Program FilesCitrixVirtual Dekstop AgentVdaEnviroment.dll

RDP into current desktop and replace the file
You might need to patch an existing image (please refer to Patching an existing image, Administrator Guide)
You might need to build new image (please refer to Creating new image versions, Administrator Guide)
You might need to restart the Citrix Desktop Service or the machine

Download private fix to Citrix VDI-in-a-box
ftp://usr_EscCustomer:support3@ftpprivates.citrix.com/privates/pawelb/LA1146/LA1146.zip

Leave a Reply

Your email address will not be published. Required fields are marked *

Turn on pictures to see the captcha *